This forum is for everyone who have a question, problem or opinion related to Composite C1.

Reporting an issue? Before reporting an issue, remember to check log files (use "Tools | Server Log" or the log viewer) for relevant warnings/exceptions. You can find raw logs in /App_Data/Composite/LogFiles. If you have found a bug please create an issue in the Issue Tracker.

Got a great feature idea? If you have a feature idea, consider also creating it in the Issue Tracker with "Feature Request: (your idea)" as title, so we may vote it up.

Need confidential support? If you need private support, go to http://www.composite.net/Products/support.

How to get user-defined datatype in a class?

first post: gringalet wrote: I build a global datatype and named it <gringalet.users> in c1 cons...

latest post: mawtex wrote: You can use this C1 Package to get the source code of data types: h...

Installing WebAPI on C1 4.2 Update 1

first post: elemental21 wrote: I'm trying to install WebAPI on 4.2 update 1 and I'm getting an err...

latest post: elemental21 wrote: I don't know to be honest. I don't remember deploying it that way ...

DataIdMultiSelector or String.Selector which is bound to the current Page-Node?

first post: Stops wrote: Hello, I'm working currently on a C1 4.2 project and have the fol...

latest post: Stops wrote: Anyone have an idea how I could solve this? Thanks for any help in...

Visual Studio context code pop-up

first post: epaquet861 wrote: Hi, I just created a Razor function from Visual Studio 2012 (with ...

Log entry The data interface 'Composite.Data.Types.IPage' will not work for the SqlDataProvider 'DynamicSqlDataProvider'

first post: sbornemann wrote: A couple of days before one of our composite sites stopped working....

Publishing error on webhotel

first post: sgedda wrote: I have published a Composite C1 web to my webhotel and they said my...

404 when special chars in URL

first post: panzerkunst wrote: Hello, I'm using Composite C1 v4 and I have a problem when there ...

latest post: napernik wrote: Hi Nicolas I've seen a similar issue on v4.0 /IIS7.5. It is hard t...

DL Definition Lists / Description Lists and PRE Blocks

first post: DBailey635 wrote: I'm trying to add definition lists / description lists to the Visua...

Blog component

first post: panzerkunst wrote: Hello, In the blog component, it would be nice to be able to choo...

Razor views in the C1 console

first post: Padwah wrote: I've created a few razor views to plugin to the C1 console followin...

latest post: Padwah wrote: Ah, no I didn't! In my tests I just had them under the root, moving...

answered by: burningice wrote: Did you make sure to put the file within the ~/Composite folder?